Service Disruption: Trip Booking and Driver App

Incident Report for Spare Platform

Postmortem

Spare Incident Report

May 16, 2026

Executive Summary

On May 16, 2026 the Spare platform experienced a significant service disruption impacting organizations within our CA data residency region. The incident was characterized by an inability to book new trips for all customers in the CA region, from both the admin and rider interfaces, as well as driver app crashes. The disruption originated from an edit made to a geography, that resulted in corrupt data, causing our Open Street Maps based routing server to crash.

Our engineering team restored service by archiving the geography causing the crashes.  Errors began at low volume at 1:35 pm PT, reached outage level at 1:42 pm PT, and service was fully restored at 2:41 pm PT.

Incident Details

The errors began in low volume at 1:35 pm PT, then ramped up to high volume at 1:42 pm PT. Our Open Street Maps Routing system servers were crashing with “segmentation fault” errors, causing an inability to book new trips for all customers in the CA region, from both the admin and rider interfaces, as well as crashing driver app navigation. After trying a number of mitigations, the cause of the segmentation faults was eventually tracked down to be a corrupt customization of a geography. Spare allows customizing geographies in two manners, and older/legacy approach using external tools and uploaded changeset files, and a newer approach using an in-platform editor. Here a file generated outside of Spare with the legacy approach was uploaded, and the built routing data, when used, caused our Open Street Maps based routing server to crash. Service was restored by archiving this geography, with service partially recovering at 2:39 pm PT, and fully recovered at 2:41 pm PT.

Cause

The primary root cause was a latent issue where a bad geography could cause our routing system to crash, which had never before occurred, but then surfaced with the uploading of these geography edits.

Resolution

Archiving the geography that was causing the crashes.

Timeline

All times are in Pacific Time (PT).

  • 1:35 pm: Errors began at low volume, minimal impact at this time
  • 1:42 pm: Errors reached high volume, major impact at this time
  • 1:45 pm: Spare on-call personnel alerted by automated alerts and investigation begins
  • 2:35 pm: Identified the geography causing the crashes, archived it
  • 2:39 pm: Partial recovery of the system
  • 2:41 pm: Full recovery

Next Steps

To prevent a recurrence of this failure, we’re undertaking the following:

  • Temporary Disabling of “Legacy” Style Geography Edits: Until we can fully understand all the details of the crash, we are preventing any new edits from being made to geographies using the “legacy” approach. Existing edits will remain, only new edits are disabled.
  • Root Cause Analysis: Fully understanding all the details of the crash.
  • Re-Enabling “Legacy” Style Geography Edits: Once the crashes are fully understood, and fixes put in place, we’ll re-enable “legacy” style geography edits.

We recognize the critical role our platform plays in your daily operations and the significant impact this outage had on your riders, administrators and drivers. We sincerely apologize for the disruption and are committed to strengthening our infrastructure to prevent a repeat of this issue, and to consistently achieve the uptime and reliability you expect from Spare.

Posted May 16, 2026 - 16:32 PDT

Resolved

We have fully restored all services following the recent service disruption this afternoon. The disruption impacted our platform in the Canada region from approximately 1:35 PM to 2:41 PM PST, during which trip bookings, vehicle location updates, and the Driver App were affected.
As of 2:44 PM PST, our engineering team has verified that all systems are completely stable and operating normally. If you continue to experience any residual lagging or minor issues, please try restarting or refreshing your app.

We sincerely apologize for the inconvenience this caused to your day and truly appreciate your patience as our teams worked to resolve this as quickly as possible.

This incident is now officially closed.
Posted May 16, 2026 - 15:10 PDT

Monitoring

We are glad to report that a fix has been applied, and we are seeing consistent signs of recovery across the platform. Service has been slowly restoring since approximately 2:40 PM PST, and most features are now back online.

Riders and drivers should now be able to schedule trips, update vehicle locations, and access the Driver App as usual. Our team will continue to monitor system performance closely for a little longer to ensure complete stability across the network. If you are still experiencing any minor delays, please try restarting or refreshing your app.

Thank you so much for your patience and support throughout this service disruption. We will post a final update once the platform is confirmed completely stable and ready to close.
Posted May 16, 2026 - 14:45 PDT

Update

We continue to actively investigate the ongoing service disruption affecting our platform
Posted May 16, 2026 - 14:38 PDT

Investigating

We are currently experiencing a service disruption affecting our platform. During this time, riders may be unable to book trips, and drivers may experience issues with vehicle location updates or accessing the Driver App.

Our team continues to investigate the root cause and is working actively with Engineering to identify a solution as quickly as possible. There are no new developments or workarounds available at this time, but we are fully focused on restoring normal operations.

We truly appreciate your continued patience and understanding. We will share our next update within 15 minutes, or as soon as new information becomes available.
Posted May 16, 2026 - 14:08 PDT
This incident affected: Spare Driver Application ([iOS], [Android]) and Administrator Portal ([Canada]).