The incident impacting platform performance and causing increased latencies in the CA (Canada) service region has been resolved as of 17:20 PDT.
Our engineering team has confirmed that services have returned to normal operation, and we will continue monitoring to ensure ongoing stability. Thank you for your patience throughout this incident.
Posted May 19, 2026 - 17:34 PDT
Monitoring
A fix has been applied for the increased latencies affecting the CA region, and platform performance has shown improvement. Our engineering team is continuing to closely monitor the environment to ensure stability and confirm full recovery.
We appreciate your patience while we worked through this issue.
Posted May 19, 2026 - 17:20 PDT
Update
We are continuing to investigate increased latencies affecting the CA region. Users may experience intermittent command timeout errors, degraded platform performance, and delays when scheduling or managing rides.
Our engineering team remains actively engaged and is working to mitigate the issue as quickly as possible.
We will provide additional updates as more information becomes available.
Posted May 19, 2026 - 17:13 PDT
Investigating
We are currently observing increased latencies across the CA region, which may result in slower-than-expected platform performance and delayed request processing. Our engineering team is actively investigating the issue and working to mitigate the impact as quickly as possible.
Further updates will be shared as they become available.
Posted May 19, 2026 - 16:58 PDT
This incident affected: Spare Rider Application ([iOS], [Android]) and Administrator Portal ([Canada]).