What happened: Some trips became stuck in an incorrect state, such as “In Progress” or “Arriving Soon,” even though they had already been completed. These trips could not be manually canceled from the admin dashboard.
• Admin Panel users were unable to book new or return trips for riders whose previous trip appeared to still be in progress. • For certain users, error messages appeared when viewing rider profiles or duties associated with the affected trips.
Resolution: We deployed a fix to ensure trip states are correctly finalized and synchronized across all systems. As part of the resolution, we also corrected the trips that had been stuck in this bad state.
If you still see any trips stuck in an incorrect status, please let us know at support@spare.com so we can notify the appropriate team for correction.
Posted Apr 18, 2025 - 10:37 PDT
Monitoring
Our teams have implemented a fix to resolve trips that were stuck in an “In progress” or “Arriving soon” state, even though they were actually completed. These trips should now be displayed as “Completed.” We are closely monitoring the situation to ensure a complete restoration of the system.
Posted Apr 18, 2025 - 09:44 PDT
Update
A few trips are still in a bad state - Our development team is working on a fix. Beyond this, all systems are go. We will update you as we progress.
Posted Apr 18, 2025 - 09:27 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 18, 2025 - 08:24 PDT
Investigating
We have identified the issue causing trips to be stuck in a bad state, preventing trips from being completed. Our development team is working on a fix. We will update you as we progress.
Posted Apr 18, 2025 - 07:47 PDT
This incident affected: Administrator Portal [United States 1], Administrator Portal [United States 2], Administrator Portal [Canada], and Administrator Portal [Japan].