The service disruption affecting passenger selections in the admin panel has been fully resolved. The fix is now active across all regions, and the system is performing normally.
We have monitored the platform closely following the deployment and can confirm that passenger types are now saving correctly and consistently. If you haven't already, please refresh your browser to ensure you are using the most up-to-date version of the platform.
We appreciate your patience and cooperation while we worked to address this issue. Our team remains committed to providing a reliable experience, and we are now closing this incident.
Posted Apr 01, 2026 - 03:57 PDT
Monitoring
The deployment of our fix for the service disruption in the admin panel remains in progress. Our Engineering team is continuing to roll out the update across all regions, and we expect this to be completed shortly.
We are keeping a close watch on the deployment to ensure that passenger selections begin saving correctly as soon as the update is live in your area. Once the rollout is complete, we recommend refreshing your browser to ensure you are seeing the most recent version of the platform.
We appreciate your continued patience during this time and will share our next update in 15 minutes.
Posted Apr 01, 2026 - 03:45 PDT
Update
We are currently deploying a fix to the platform. This deployment is expected to take approximately 10-15 minutes to complete.
Once the fix is fully applied, you should see immediate improvement when saving passenger selections in the admin panel. We recommend that all dispatchers refresh their browsers in about 10 minutes to ensure the update is active.
We are monitoring the progress of this rollout closely and will share another update within 15 minutes. Thank you for bearing with us as we work to restore full service.
Posted Apr 01, 2026 - 03:27 PDT
Update
We are still actively working toward a resolution for the service disruption impacting passenger selections in the admin panel. Our Engineering team continues to address the processing delays identified earlier to ensure that all background updates and passenger data are saved consistently.
There are no new developments to share at this time, but please be assured that this remains our top priority. We continue to recommend manually verifying passenger types immediately after creating a request as a temporary workaround. We truly appreciate your continued patience and will share our next update in 15 minutes or as soon as more information becomes available.
Posted Apr 01, 2026 - 03:11 PDT
Identified
Our Engineering team has successfully identified the root cause of the service disruption where passenger selections were reverting in the admin panel. The issue is related to a delay in how our system processes specific background updates, which prevents passenger changes from being confirmed in real-time. This delay causes a backlog that prevents certain information from saving correctly during the booking process.
The impact remains the same, affecting dispatchers across all regions. Our team is now focused on addressing these processing delays to ensure all passenger data saves consistently and correctly moving forward.
While we work on the resolution, please continue to verify passenger types immediately after creating a request. We do not have a specific ETA for the fix yet, but we are working with the highest priority and will share our next update in 15 minutes. Thank you for your continued patience
Posted Apr 01, 2026 - 02:50 PDT
Investigating
We are currently investigating a service disruption affecting the admin panel, specifically concerning passenger type selections during the booking process. When attempting to change a passenger count and category (e.g., from "1 Adult" to "1 Person with Disability,") the selection may revert to "1 Adult" upon creating request.
This disruption is impacting all regions and is specifically affecting dispatchers booking requests through the admin panel. Our Engineering team has confirmed this is a frontend issue and is actively working to implement a fix to ensure passenger selections are submitted correctly.
While we work on a resolution, please double-check passenger details after a request is created to ensure accuracy. We are committed to restoring full functionality and will provide our next update within 15 minutes. Thank you for your patience and understanding.
Posted Apr 01, 2026 - 02:37 PDT
This incident affected: Administrator Portal ([United States 1], [Canada], [United States 2], [Japan]).