General Slowness Affecting Spare Platform

Incident Report for Spare Platform

Resolved

The service degradation for the Spare Admin Platform has been resolved. Our Engineering Team has identified that services are now fully operational, and no further action is due at the moment. If any of the users from your organization is still experiencing slowness, perform a hard-refresh on the browser and contact Spare Support if any other not expected behaviours arise.
Posted Dec 15, 2025 - 15:16 PST

Update

Our Engineering Team has found out that database errors for the services affected today have been stabilized after a fix for the issue was deployed. Some users might still be experiencing general slowness, we continue to monitor the behaviour of the affected components.
Posted Dec 15, 2025 - 15:15 PST

Update

Our Engineering Team has found out that database errors for the services affected today have been stabilized after a fix for the issue was deployed. Some users might still be experiencing general slowness, we continue to monitor the behaviour of the affected components.
Posted Dec 15, 2025 - 15:00 PST

Monitoring

Our Engineering Team has found out that database errors for the services affected today have been stabilized after a fix for the issue was deployed. Some users might still be experiencing general slowness, we continue to monitor the behaviour of the affected components.
Posted Dec 15, 2025 - 14:45 PST

Update

Our Engineering Team is still investigating this issue and has not provided new updates at the time. We will update you as soon as they provide news on the resolution.
Posted Dec 15, 2025 - 14:30 PST

Update

Our Engineering Team is still investigating this issue and has not provided new updates at the time. We will update you as soon as they provide news on the resolution.
Posted Dec 15, 2025 - 14:15 PST

Update

Our Engineering Team is still investigating this issue and has not provided new updates at the time. We will update you as soon as they provide news on the resolution.
Posted Dec 15, 2025 - 14:00 PST

Update

Our Engineering Team is still investigating this issue and has not provided new updates at the time. We will update you as soon as they provide news on the resolution.
Posted Dec 15, 2025 - 13:45 PST

Update

Our Engineering Team is still investigating this issue and has not provided new updates at the time. We will update you as soon as they provide news on the resolution.
Posted Dec 15, 2025 - 13:30 PST

Investigating

We are currently investigating issues related to general slowness within the Spare Admin Platform. Users might be seeing Timeout errors and long loading times. Our Engineering Team is promptly working to resolve this incident, appreciate your patience throughout the investigation phase.
Posted Dec 15, 2025 - 13:15 PST
This incident affected: Administrator Portal ([United States 1], [Canada], [United States 2], [Japan]).