A fix has been successfully applied, and we are seeing full recovery across the platform for the service disruption that was impacting the live map and Analytics V1 for organizations in the Canada (CA) region. Most users should now see the map loading properly with up-to-date vehicle information and should be able to access Analytics information. If you continue to experience any issues, please refresh your page or application. Thank you for your patience and understanding throughout this incident.
Posted Dec 02, 2025 - 17:55 PST
Identified
The Engineering Team has identified a fix for the behaviour causing issues to load the Live Map and will be deploying it soon.
Posted Dec 02, 2025 - 17:52 PST
Update
There are no new developments at the moment, and the team continues to investigate.
Posted Dec 02, 2025 - 17:42 PST
Update
There are no new developments at the moment, and the team continues to investigate.
Posted Dec 02, 2025 - 17:27 PST
Update
There are no new developments at the moment, and the team continues to investigate.
Posted Dec 02, 2025 - 17:12 PST
Investigating
We are currently investigating a service disruption affecting the live map feature in our platform. Users within the Canada (CA) region may be experiencing issues where the Live Map is not loading properly, as well as problems loading Analytics V1 pages. This can manifest as a constant loading screen, or a map view that is missing vehicle information. Our team is actively working with Engineering to identify the cause of this behavior and will share more details as soon as they are available. We understand the importance of this feature, and we appreciate your patience as we work toward a resolution. We will post an update within the next 15 minutes or sooner if new information emerges.
Posted Dec 02, 2025 - 16:57 PST
This incident affected: Administrator Portal ([Canada]).