We identified an issue causing intermittent platform latency. We have since implemented a fix, and our engineering team confirms that performance has stabilized. All services are now operating within normal parameters.
We will continue to monitor the environment for the next hour to ensure ongoing reliability. Thank you for your patience while we resolved this.
Posted Mar 10, 2026 - 10:15 PDT
Update
We're still investigating - We identified an issue causing intermittent platform latency. We will continue to monitor the environment for the next hour to ensure ongoing reliability. Thank you for your patience while we resolve this.
Posted Mar 10, 2026 - 09:50 PDT
Identified
We're still investigating - We identified an issue causing intermittent platform latency. We will continue to monitor the environment for the next hour to ensure ongoing reliability. Thank you for your patience while we resolve this.
Posted Mar 10, 2026 - 09:35 PDT
Monitoring
We identified an issue causing intermittent platform latency. We will continue to monitor the environment for the next hour to ensure ongoing reliability. Thank you for your patience while we resolve this.
Posted Mar 10, 2026 - 09:20 PDT
This incident affected: Administrator Portal ([Canada]).