Our engineers have successfully resolved the technical issue affecting the Live Map. Vehicles should now be appearing correctly and in real-time for all US-based users.
Status: All systems are back to normal.
Live Map: Accuracy has been restored; lagging and incorrect statuses are resolved.
Operations: Continue as usual, now with full visibility.
Thank you for your patience while we smoothed out the data sync. It's all up and running!
Posted Feb 18, 2026 - 06:04 PST
Update
This is still under investigation - We’re investigating reports of vehicles appearing offline on the Live Map for certain US-based users. Our engineers are on the case to restore the map view as quickly as possible.
Impact: Active duties and trips are not affected, operations continue as usual, though please be aware the map may lag or show incorrect status for now. We’ll keep you posted as we learn more.
Posted Feb 18, 2026 - 05:27 PST
Update
This is still under investigation - We’re investigating reports of vehicles appearing offline on the Live Map for certain US-based users. Our engineers are on the case to restore the map view as quickly as possible.
Impact: Active duties and trips are not affected, operations continue as usual, though please be aware the map may lag or show incorrect status for now. We’ll keep you posted as we learn more.
Posted Feb 18, 2026 - 05:11 PST
Update
This is still under investigation - We’re investigating reports of vehicles appearing offline on the Live Map for certain US-based users. Our engineers are on the case to restore the map view as quickly as possible.
Impact: Active duties and trips are not affected, operations continue as usual, though please be aware the map may lag or show incorrect status for now. We’ll keep you posted as we learn more.
Posted Feb 18, 2026 - 04:56 PST
Update
This is still under investigation - We’re investigating reports of vehicles appearing offline on the Live Map for certain US-based users. Our engineers are on the case to restore the map view as quickly as possible.
Impact: Active duties and trips are not affected, operations continue as usual, though please be aware the map may lag or show incorrect status for now. We’ll keep you posted as we learn more.
Posted Feb 18, 2026 - 04:41 PST
Update
This is still under investigation - We’re investigating reports of vehicles appearing offline on the Live Map for certain US-based users. Our engineers are on the case to restore the map view as quickly as possible.
Impact: Active duties and trips are not affected, operations continue as usual, though please be aware the map may lag or show incorrect status for now. We’ll keep you posted as we learn more.
Posted Feb 18, 2026 - 04:26 PST
Update
This is still under investigation - We’re investigating reports of vehicles appearing offline on the Live Map for certain US-based users. Our engineers are on the case to restore the map view as quickly as possible.
Impact: Active duties and trips are not affected, operations continue as usual, though please be aware the map may lag or show incorrect status for now. We’ll keep you posted as we learn more.
Posted Feb 18, 2026 - 04:11 PST
Update
This is still under investigation - We’re investigating reports of vehicles appearing offline on the Live Map for certain US-based users. Our engineers are on the case to restore the map view as quickly as possible.
Impact: Active duties and trips are not affected, operations continue as usual, though please be aware the map may lag or show incorrect status for now. We’ll keep you posted as we learn more.
Posted Feb 18, 2026 - 03:56 PST
Update
This is still under investigation - We’re investigating reports of vehicles appearing offline on the Live Map for certain US-based users. Our engineers are on the case to restore the map view as quickly as possible.
Impact: Active duties and trips are not affected, operations continue as usual, though please be aware the map may lag or show incorrect status for now. We’ll keep you posted as we learn more.
Posted Feb 18, 2026 - 03:41 PST
Update
This is still under investigation - We’re investigating reports of vehicles appearing offline on the Live Map for certain US-based users. Our engineers are on the case to restore the map view as quickly as possible.
Impact: Active duties and trips are not affected, operations continue as usual, though please be aware the map may lag or show incorrect status for now. We’ll keep you posted as we learn more.
Posted Feb 18, 2026 - 03:26 PST
Update
We are currently investigating an issue where the Live Map is showing vehicles as offline for some users in the US region. Our engineering team is actively reviewing the issue to determine the cause and restore normal map functionality as quickly as possible.
Trips in progress and active duties are not impacted by this issue. Please continue operations as normal, but be aware that the Live Map view may not accurately reflect vehicle locations until the issue is resolved.
We will provide updates as soon as more information becomes available.
Posted Feb 18, 2026 - 03:11 PST
Investigating
We are currently investigating an issue where the Live Map is showing vehicles as offline for some users in the US region. Our engineering team is actively reviewing the issue to determine the cause and restore normal map functionality as quickly as possible.
Trips in progress and active duties are not impacted by this issue. Please continue operations as normal, but be aware that the Live Map view may not accurately reflect vehicle locations until the issue is resolved.
We will provide updates as soon as more information becomes available.
Posted Feb 18, 2026 - 02:56 PST
This incident affected: Administrator Portal ([United States 1]).