Performance Issues and Unexpected Delays In Features Behavior.

Incident Report for Spare Platform

Resolved

A solution has been implemented, and platform performance has returned to normal levels. All features are now fully operational. We apologize for the disruption and appreciate your patience while we worked to resolve this.
Posted Dec 11, 2025 - 06:54 PST

Update

Our engineering team is continuing to work on resolving this issue. We do not have a definitive time for resolution yet, but this remains our top priority. We will provide another update as soon as we have more information.
Posted Dec 11, 2025 - 06:36 PST

Identified

We are currently investigating reports of performance issues affecting our platform. Users may experience slower load times and unexpected delays when using certain features.

Our engineering team has identified the cause and is working to restore full service stability as quickly as possible. We apologize for the disruption and will provide further updates shortly.
Posted Dec 11, 2025 - 06:19 PST
This incident affected: Administrator Portal ([United States 1]).