Support Communications Performance Degradation

Incident Report for Spare Platform

Resolved

Intercom has marked this incident as resolved and all customer communications should be back to normal. We kindly apologize for any inconveniences this might have caused.

You can follow Intercom’s Status Page for real-time updates: https://www.intercomstatus.com/us-hosting
Posted Oct 20, 2025 - 14:54 PDT

Update

No new information from Intercom at this time. We’re continuing to monitor their status and will share updates as they become available.

You can follow Intercom’s Status Page for real-time updates: https://www.intercomstatus.com/us-hosting
Posted Oct 20, 2025 - 14:39 PDT

Update

No new information from Intercom at this time. We’re continuing to monitor their status and will share updates as they become available.

You can follow Intercom’s Status Page for real-time updates: https://www.intercomstatus.com/us-hosting
Posted Oct 20, 2025 - 14:24 PDT

Update

No new information from Intercom at this time. We’re continuing to monitor their status and will share updates as they become available.

You can follow Intercom’s Status Page for real-time updates: https://www.intercomstatus.com/us-hosting
Posted Oct 20, 2025 - 14:09 PDT

Update

No new information from Intercom at this time. We’re continuing to monitor their status and will share updates as they become available.

You can follow Intercom’s Status Page for real-time updates: https://www.intercomstatus.com/us-hosting
Posted Oct 20, 2025 - 13:54 PDT

Update

No new information from Intercom at this time. We’re continuing to monitor their status and will share updates as they become available.

You can follow Intercom’s Status Page for real-time updates: https://www.intercomstatus.com/us-hosting
Posted Oct 20, 2025 - 13:39 PDT

Update

No new information from Intercom at this time. We’re continuing to monitor their status and will share updates as they become available.

You can follow Intercom’s Status Page for real-time updates: https://www.intercomstatus.com/us-hosting
Posted Oct 20, 2025 - 13:24 PDT

Update

No new information from Intercom at this time. We’re continuing to monitor their status and will share updates as they become available.

You can follow Intercom’s Status Page for real-time updates: https://www.intercomstatus.com/us-hosting
Posted Oct 20, 2025 - 13:09 PDT

Update

No new information from Intercom at this time. We’re continuing to monitor their status and will share updates as they become available.

You can follow Intercom’s Status Page for real-time updates: https://www.intercomstatus.com/us-hosting
Posted Oct 20, 2025 - 12:54 PDT

Update

No new information from Intercom at this time. We’re continuing to monitor their status and will share updates as they become available.

You can follow Intercom’s Status Page for real-time updates: https://www.intercomstatus.com/us-hosting
Posted Oct 20, 2025 - 12:39 PDT

Update

No new information from Intercom at this time. We’re continuing to monitor their status and will share updates as they become available.

You can follow Intercom’s Status Page for real-time updates: https://www.intercomstatus.com/us-hosting
Posted Oct 20, 2025 - 12:24 PDT

Update

No new information from Intercom at this time. We’re continuing to monitor their status and will share updates as they become available.

You can follow Intercom’s Status Page for real-time updates: https://www.intercomstatus.com/us-hosting
Posted Oct 20, 2025 - 12:09 PDT

Update

No new information from Intercom at this time. We’re continuing to monitor their status and will share updates as they become available.

You can follow Intercom’s Status Page for real-time updates: https://www.intercomstatus.com/us-hosting
Posted Oct 20, 2025 - 11:54 PDT

Update

No new information from Intercom at this time. We’re continuing to monitor their status and will share updates as they become available.

You can follow Intercom’s Status Page for real-time updates: https://www.intercomstatus.com/us-hosting
Posted Oct 20, 2025 - 11:39 PDT

Update

No new information from Intercom at this time. We’re continuing to monitor their status and will share updates as they become available.

You can follow Intercom’s Status Page for real-time updates: https://www.intercomstatus.com/us-hosting
Posted Oct 20, 2025 - 11:24 PDT

Update

No new information from Intercom at this time. We’re continuing to monitor their status and will share updates as they become available.

You can follow Intercom’s Status Page for real-time updates: https://www.intercomstatus.com/us-hosting
Posted Oct 20, 2025 - 11:09 PDT

Update

No new information from Intercom at this time. We’re continuing to monitor their status and will share updates as they become available.

You can follow Intercom’s Status Page for real-time updates: https://www.intercomstatus.com/us-hosting
Posted Oct 20, 2025 - 10:54 PDT

Update

No new information from Intercom at this time. We’re continuing to monitor their status and will share updates as they become available.

You can follow Intercom’s Status Page for real-time updates: https://www.intercomstatus.com/us-hosting
Posted Oct 20, 2025 - 10:39 PDT

Update

No new information from Intercom at this time. We’re continuing to monitor their status and will share updates as they become available.
Posted Oct 20, 2025 - 10:25 PDT

Update

No new information from Intercom at this time. We’re continuing to monitor their status and will share updates as they become available.

You can follow Intercom’s Status Page for real-time updates: https://www.intercomstatus.com/us-hosting
Posted Oct 20, 2025 - 10:05 PDT

Update

No new information from Intercom at this time. We’re continuing to monitor their status and will share updates as they become available.

You can follow Intercom’s Status Page for real-time updates: https://www.intercomstatus.com/us-hosting
Posted Oct 20, 2025 - 09:47 PDT

Monitoring

Our support communications platform, Intercom, is currently experiencing issues due to a major outage affecting Amazon Web Services (AWS).
This is causing slowness and intermittent errors within the platform, which may lead to delays in our responses.

Our team remains available and will continue to monitor the situation closely. Response times may vary until Intercom’s services are fully restored.

For ongoing updates, please visit Intercom’s Status Page: https://www.intercomstatus.com/us-hosting
Posted Oct 20, 2025 - 09:27 PDT
This incident affected: Customer Support (Intercom Email, Intercom Chats and Posts).