Platform performance has returned to normal, and all services are operating as expected.
Our team will continue conducting a deeper root cause analysis, and Partner Success Managers will follow up in the coming days with additional details. We apologize for any inconveniences this may have created — and appreciate your partnership & patience while we worked on this.
Posted Mar 26, 2026 - 11:22 PDT
Update
The issue impacting platform performance has stabilized, and we are currently seeing recovery across affected services.
Our team is continuing to monitor closely to ensure stability, while we conduct a root cause analysis. Further updates will be shared as more information becomes available.
Posted Mar 26, 2026 - 11:19 PDT
Monitoring
The issue impacting platform performance has stabilized, and we are currently seeing recovery across affected services.
Our team is continuing to monitor closely to ensure stability, while we conduct a root cause analysis. Further updates will be shared as more information becomes available.
Posted Mar 26, 2026 - 11:04 PDT
Update
We are continuing to investigate the issue impacting platform performance. At this time, we have not received additional updates, but our engineering team remains actively engaged.
We’ll share more information as soon as it becomes available or in the next 15 minutes.
Posted Mar 26, 2026 - 10:49 PDT
Investigating
We are currently investigating an issue impacting platform performance. Users may experience slower response times or intermittent issues across the application.
Our engineering team has identified the area of impact and is actively working to mitigate the issue. We will provide further updates as soon as more information becomes available.
Posted Mar 26, 2026 - 10:34 PDT
This incident affected: Administrator Portal ([United States 1]).